Zeichenfehler

Noch irgendwelche Fragen zum InuYasha-FanProjekt oder zu diesem Forum? Hier könnt ihr sie stellen und/oder beantworten

Moderatoren: Neko, EVA-01, blue

Zeichenfehler

Beitragvon Sebijk » So Feb 13, 2011 4:03 pm

Muss ich wohl nicht grossartig erwaehnen. Man sieht in vielen aelteren Beitraegen nun Zeichenfehler bei Umlauten.

zudem kommt das, wenn ich versuche, Umlaute zu nutzen:

Could not insert new word matches

DEBUG MODE

SQL Error : 1271 Illegal mix of collations for operation ' IN '

INSERT INTO phpbb_search_wordmatch (post_id, word_id, title_match) SELECT 62652, word_id, 0 FROM phpbb_search_wordlist WHERE word_text IN ('grossartig', 'erwaehnen', 'sieht', 'vielen', 'aelteren', 'beitraegen', 'zeichenfehler', 'umlauten')

Line : 251
File : functions_search.php
Sebijk
 
Beiträge: 268
Registriert: Sa Aug 08, 2009 1:14 am
Wohnort: München(Bayern) / Bottrop(NRW)

Beitragvon Asuma » So Feb 13, 2011 4:31 pm

Joar, ich hab es eben auch bemerkt, als ich hier her kam (hab gerade eine e-mail erhalten xD).

Anscheinend wurde der Zeichensatz der Datebank veraendert, oder der Zeichensatz der Datenbankverbindung...

Schaetze mal, das wird nicht nochmal geaendert, heh?
Benutzeravatar
Asuma
 
Beiträge: 41
Registriert: So Okt 29, 2006 11:59 am
Wohnort: Köln

Beitragvon EVA-01 » So Feb 13, 2011 4:34 pm

Asuma hat geschrieben:Schaetze mal, das wird nicht nochmal geaendert, heh?


Ich wuerd's gerne aendern. Wenn mir jemand sagt wie und wo. Ich hab keine Ahnung von phpbb2, nur bin ich dummerweise der einzige verbliebene aktive Admin, da blue leider verhindert ist...
Benutzeravatar
EVA-01
Doktor der Mensalogie
 
Beiträge: 554
Registriert: Di Nov 09, 2004 7:46 pm
Wohnort: Fulda

Beitragvon Asuma » So Feb 13, 2011 5:49 pm

Hast du die M?glichkeit ein Backup zu machen? Dann k?nnte man im Backup mit Programmen wie Notepad++ einfach alle komischen Symbole ersetzen lassen und dann das backup wieder einspielen.

Ich wei? nicht, ob phpBB2 schon eine Backup funktion besitzt, so wie es in phpBB3 der Fall ist.

Oder vielleicht w?re ein update auf phpBB3 besser?
Benutzeravatar
Asuma
 
Beiträge: 41
Registriert: So Okt 29, 2006 11:59 am
Wohnort: Köln

Beitragvon Neko » So Feb 13, 2011 9:40 pm

Auf Lukis Wunsch mal ein Testbeitrag

? ? ? ? y


Die alten Beitraege kann man allerdings normal lesen, wenn man den Code auf UTF 8 stellt. Die neueren Beitraege allerdings nicht.


Neko
kelpie: "Die Katze ist kaputt, die schnurrt unregelmäßig"
Benutzeravatar
Neko
大妖怪 (Daiyoukai)
 
Beiträge: 8613
Registriert: Mi Okt 26, 2005 6:18 pm
Wohnort: Berlin

Beitragvon Sebijk » So Feb 13, 2011 11:04 pm

mhm, also bei den neuen Beitraegen sehe ich nur Fragezeichen in Umlauten.

Aber Danke fuer den Hinweis bzgl. UTF-8. Es koennte sein, dass intern die MySQL-Datenbank aktualisiert wurde (ob es stimmt, weiss ich nicht, nur ne Schaetzung).

Der Header des Forums sendet noch iso-8859-1 aus, es koennte also auch reichen, wenn nur der Header auf UTF-8 Encoding geaendert wird. Dann koennte es aber sein, dass die Sprachdateien falsch dargestellt werden, laesst sich aber sehr einfach beheben, indem man die Sprachdateien oeffnet und als UTF-8 abspeichert.
Sebijk
 
Beiträge: 268
Registriert: Sa Aug 08, 2009 1:14 am
Wohnort: München(Bayern) / Bottrop(NRW)

Beitragvon Neko » So Feb 13, 2011 11:40 pm

Sebijk hat geschrieben:mhm, also bei den neuen Beitraegen sehe ich nur Fragezeichen in Umlauten.


Jepp, bei den neueren Beitraegen, also von heute, und bei dem ganzen drumherum im Forum wirkt die Umstellung auf UTF-8 nicht.


Neko
kelpie: "Die Katze ist kaputt, die schnurrt unregelmäßig"
Benutzeravatar
Neko
大妖怪 (Daiyoukai)
 
Beiträge: 8613
Registriert: Mi Okt 26, 2005 6:18 pm
Wohnort: Berlin

Beitragvon Asuma » So Feb 13, 2011 11:51 pm

Das mit dem Encoding hab ich bereits zwar oben schon erw?hnt, aber egal ;)

Das Problem liegt eher an phpBB2. Das gibt weiterhin ISO-8859-1 aus, wird aber halt dann f?r UTF-8 gehalten. Ob dann die Fragezeichen verschwinden, ist die andere Frage. phpBB2 hatte schon immer Probleme mit bestimmten UTF-8 Symbolen und konnte die nicht richtig darstellen.

Da wird wohl die MySQL Version aktualisiert worden sein und auch die Verbindungseinstellung ge?ndert, da neuere Versionen von MySQL automatisch UTF-8 als Kodierung ausgeben.

In phpBB3 wurde dies behoben. :)
Benutzeravatar
Asuma
 
Beiträge: 41
Registriert: So Okt 29, 2006 11:59 am
Wohnort: Köln

Beitragvon Sebijk » Di Feb 15, 2011 5:54 pm

Also ich wuerde da mal langsam etwas machen, sonst hat man hier am Ende nur noch Aerger und Zeichensalat. Zumal wuerden sich nun Nutzer mit Umlaute wundern, dass sie sich nicht mehr einloggen koennen.

Wenn Nutzern Umlaute benutzen, dann kommt ja wie gesagt, diese Datenbankfehlermeldung. Ausserdem wird auf der Startseite somit nicht angezeigt, wer was neues geschrieben hat.

Hab ja meine Hilfe angeboten und kenne das Problem selber.
Sebijk
 
Beiträge: 268
Registriert: Sa Aug 08, 2009 1:14 am
Wohnort: München(Bayern) / Bottrop(NRW)

Beitragvon EVA-01 » Di Feb 15, 2011 6:50 pm

Sebijk hat geschrieben:Also ich wuerde da mal langsam etwas machen, sonst hat man hier am Ende nur noch Aerger und Zeichensalat. Zumal wuerden sich nun Nutzer mit Umlaute wundern, dass sie sich nicht mehr einloggen koennen.

Wenn Nutzern Umlaute benutzen, dann kommt ja wie gesagt, diese Datenbankfehlermeldung. Ausserdem wird auf der Startseite somit nicht angezeigt, wer was neues geschrieben hat.

Hab ja meine Hilfe angeboten und kenne das Problem selber.


Blue wollte sich drum k?mmern... wenn's am Donnerstag noch nichts Neues gibt, klingel ich mal bei ihm durch und werd mich dann bei dir r?ckmelden, Sebijk. ^^;

Thx f?r das Angebot.
Benutzeravatar
EVA-01
Doktor der Mensalogie
 
Beiträge: 554
Registriert: Di Nov 09, 2004 7:46 pm
Wohnort: Fulda

Beitragvon Neko » Mi Feb 16, 2011 8:01 pm

Wieso diese Eile?

Nun, das ganze Problem ist ja erst seit Sonntag, durch einen, wenn ich blue richtig verstanden hatte, Serverumzug. Also besteht das Problem ja noch nicht so lange.

Und die Problematik mit der Zeichenkodierung ist ja nicht so was neues, wie man hier sehen kann: http://forum.mysqldumper.de/viewtopic.php?p=18365
Man findet weitere Infos darueber im phpbb-Forum, btw.

Es ist ja bekannt, da? blue zur Zeit etwas Probleme mit dem Schreiben hat, und somit erst jemanden fragen muss, der ihm bei der Loesung des Problems hilft, z.B. fuer ihn das Schreiben uebernimmt. Nun, ich denke mal, dass sowohl blue wie auch seine Bekannten nicht nur daeumchendrehend zu Hause sitzen, sondern noch einer Taetigkeit nachgehen. Daher kann es auch vielleicht etwas dauern, bis jemand Zeit hat. Und das vielleicht auch etwas Zeit vergeht, bis man alles durchgegangen ist, sollte auch verstaendlich sein.

Wenn also das ganze nicht am Donnerstag geloest ist, sondern etwas laenger dauert, ist das auch nicht weiter schlimm. Ist ja nicht so, dass dieses Forum zur Zeit vor Aktivitaet sprueht.



Neko
kelpie: "Die Katze ist kaputt, die schnurrt unregelmäßig"
Benutzeravatar
Neko
大妖怪 (Daiyoukai)
 
Beiträge: 8613
Registriert: Mi Okt 26, 2005 6:18 pm
Wohnort: Berlin

Beitragvon Asuma » Mi Feb 16, 2011 8:09 pm

Oder wahrscheinlich in n?chster Zeit haben wird. Es schaut halt nur h?sslich aus mit diesen ? und komischen Symbolen ?berall xD
Benutzeravatar
Asuma
 
Beiträge: 41
Registriert: So Okt 29, 2006 11:59 am
Wohnort: Köln

Beitragvon Kagome1990 » Mi Feb 16, 2011 8:11 pm

Ich find Neko hat Recht, es gibt ja auch ein Sprichwort: "In der Ruhe liegt die Kraft"
Bild
Benutzeravatar
Kagome1990
Juwelendetektor
 
Beiträge: 4080
Registriert: Mi Jan 04, 2006 1:08 pm
Wohnort: Magdeburg

Beitragvon Neko » Mi Feb 16, 2011 8:24 pm

Asuma hat geschrieben:Oder wahrscheinlich in n?chster Zeit haben wird. Es schaut halt nur h?sslich aus mit diesen ? und komischen Symbolen ?berall xD


Nun, die Zeichenkodierung im Browser auf UTF-8 umzustellen, ist zwar nervig, aber machbar. Und fuer die naechste Zeit einfach mal ae, oe etc zu schreiben, ist auch machbar. ;)

Ich erinnere mich, dass KnK auch mal das Problem hatte und es ging dort auch. ;)

Und soviel wird hier ja nicht geschrieben.^^ Die wirklich z.Z. aktiven User kann man ja schon fast an 2 Haenden abzaehlen. *g*


Neko
kelpie: "Die Katze ist kaputt, die schnurrt unregelmäßig"
Benutzeravatar
Neko
大妖怪 (Daiyoukai)
 
Beiträge: 8613
Registriert: Mi Okt 26, 2005 6:18 pm
Wohnort: Berlin

Beitragvon Asuma » Mi Feb 16, 2011 10:44 pm

Arg XD Ich h?tte vielleicht quotieren sollen ^^

Ist ja nicht so, dass dieses Forum zur Zeit vor Aktivitaet sprueht.
Oder wahrscheinlich in n?chster Zeit haben wird.


Ehrlich gesagt w?sste ich auch nicht, was ich hier im Forum machen soll. Mit einer handvoll Leuten ?ber ein FanProjekt von InuYasha zu reden, was ja mittlerweile Tod ist...

Ich muss ehrlich zugeben ich wusste damals, als ich mich angemeldet hatte, nicht das dies hier das offizielle Forum f?r die ?bersetzungen war (o_O).
Benutzeravatar
Asuma
 
Beiträge: 41
Registriert: So Okt 29, 2006 11:59 am
Wohnort: Köln

Beitragvon Sebijk » Do Feb 17, 2011 10:13 pm

ist schon klar, sieht jedoch etwas bloed aus, da es halt das offizielle Forum fuer das Fanprojekt ist.

Im uebrigen, http://www.iyfp.de geht auch nicht mehr.
Sebijk
 
Beiträge: 268
Registriert: Sa Aug 08, 2009 1:14 am
Wohnort: München(Bayern) / Bottrop(NRW)

Beitragvon Neko » Do Feb 17, 2011 10:49 pm

Sebijk hat geschrieben:Im uebrigen, http://www.iyfp.de geht auch nicht mehr.


Ist schon laenger bekannt und hat nichts mit diesem Problem hier zu tun. Das Forum ist zur Zeit nur ?ber www.tarigon.de/forum/ erreichbar. (hm, ich glaube die Info steht nur im Chat...)


Neko
kelpie: "Die Katze ist kaputt, die schnurrt unregelmäßig"
Benutzeravatar
Neko
大妖怪 (Daiyoukai)
 
Beiträge: 8613
Registriert: Mi Okt 26, 2005 6:18 pm
Wohnort: Berlin

Beitragvon Sei » Di Mär 01, 2011 1:09 am

Neko hat geschrieben:[...](hm, ich glaube die Info steht nur im Chat...)


Neko


Jep!
Ich bin keine Signatur -.-
Benutzeravatar
Sei
kitsune vampir
 
Beiträge: 3111
Registriert: Sa Apr 01, 2006 8:43 pm
Wohnort: Hamburg

Beitragvon Asuma » Di Mär 01, 2011 1:13 am

Welcher chat?
Benutzeravatar
Asuma
 
Beiträge: 41
Registriert: So Okt 29, 2006 11:59 am
Wohnort: Köln

Beitragvon Neko » Do Mär 03, 2011 11:48 pm

Der, in diesem Threaderwaehnte. ;)

Aber es gab damals ja auch ne email dazu. Link
(weiter unten den Beitrag ;) )


Neko
kelpie: "Die Katze ist kaputt, die schnurrt unregelmäßig"
Benutzeravatar
Neko
大妖怪 (Daiyoukai)
 
Beiträge: 8613
Registriert: Mi Okt 26, 2005 6:18 pm
Wohnort: Berlin

Beitragvon Sebijk » Fr Mär 11, 2011 5:22 pm

Generelle Frage: Jetzt wo blue leider von uns gegangen ist, wie geht es mit dem Forum und seiner Homepage weiter? Es ist ja noch alles auf seinen Namen angemeldet. Er hatte damals gesagt, er laesst alles online, damit jeder sich die Sachen anschauen kann. Wird es so bleiben? Waere schade, wenn es irgendwann ploetzlich weg waere, weil ja schon genug Fanseiten im deutschsprachigen Raum verschwunden bzw. offline sind.
Sebijk
 
Beiträge: 268
Registriert: Sa Aug 08, 2009 1:14 am
Wohnort: München(Bayern) / Bottrop(NRW)

Beitragvon Asuma » Fr Mär 11, 2011 5:58 pm

Die Frage ist, wer bezahlt den die HP und die Domains?

Und wer im Fall der F?lle die Aufgaben ?bernimmt..
Benutzeravatar
Asuma
 
Beiträge: 41
Registriert: So Okt 29, 2006 11:59 am
Wohnort: Köln

Beitragvon Neko » Fr Mär 11, 2011 8:37 pm

Keine Sorge, das Forum geht weiter. Das ist bereits alles geklaert. Wir werden auf jeden Fall euch auf dem Laufenden halten.


Neko
kelpie: "Die Katze ist kaputt, die schnurrt unregelmäßig"
Benutzeravatar
Neko
大妖怪 (Daiyoukai)
 
Beiträge: 8613
Registriert: Mi Okt 26, 2005 6:18 pm
Wohnort: Berlin

Beitragvon Sebijk » Mo Mai 02, 2011 10:05 pm

und wo bleiben die Neuigkeiten? :D
Sebijk
 
Beiträge: 268
Registriert: Sa Aug 08, 2009 1:14 am
Wohnort: München(Bayern) / Bottrop(NRW)

Beitragvon EVA-01 » Do Mai 05, 2011 11:27 pm

Keine Sorge, das ist schon in der Mache... lange duerfte es nicht mehr dauern. Es wird alles geregelt. ^^;
Benutzeravatar
EVA-01
Doktor der Mensalogie
 
Beiträge: 554
Registriert: Di Nov 09, 2004 7:46 pm
Wohnort: Fulda


Zurück zu Servicepoint

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast

cron